Latest Forum Posts

Latest News Posts
Coming Soon!
Social
Go Back   Techgage.com > Archives > Reviews and Articles

Reviews and Articles Discussion for Techgage content is located here. Only staff can create topics, but everyone is welcome to post.

Reply
 
Thread Tools
Old 11-08-2006, 08:55 PM   #31
bildge_rat
Obliviot
 
Join Date: Nov 2006
Posts: 2
Default

Speaking of the lighting on the Eclipse... has anyone noticed that the board seems to flicker in your peripheral vision when used in a dark room? I found this to be mildly distracting at first but easily remedied by turning the brightness down. Having not have used a "Deck" I would wonder if this effect might not be worse with a brighter board.
bildge_rat is offline   Reply With Quote
Old 11-08-2006, 09:48 PM   #32
Greg King
I just kinda show up...
 
Greg King's Avatar
 
Join Date: Jul 2005
Location: Indiana
Posts: 2,085
Default

I have not noticed this at all. Quite possibly though, I am just not attentive. Thanks for the comments and welcome to the forum.
__________________
"It is far better to grasp the universe as it really is than to persist in delusion, however satisfying and reassuring."
- Carl Sagan

System:
Intel i5 2500K | Gigabyte GA-Z68XP-UD4 | 16GB G.Skill DDR3 | Crucial M4 128GB SSD
WD 1TB Black x1 | WD 2TB Green x 1 | EVGA 660 Ti Superclocked | Corsair H80 Water Cooler
Fractal Design R3 | Windows 7 Ultimate x64 | Dell 2410 x 3 @ 1920x1200

ESXi Host:
Intel i7 920 @ 3.0 GHz | Gigabyte GA-EX58-UD4P | 24GB Patriot DDR3 | WD 1TB Black x 2
Greg King is offline   Reply With Quote
Old 11-23-2006, 08:35 AM   #33
Unregistered
Guest Poster
 
Posts: n/a
Default what

what is the size of the keyboard?
  Reply With Quote
Old 04-20-2007, 09:20 AM   #34
zard
Guest Poster
 
Posts: n/a
Default

I've just recieved my eclipse II and also had the winamp probs, but luckily found the answer here reading the comments

Nice review
  Reply With Quote
Old 04-20-2007, 10:06 AM   #35
Greg King
I just kinda show up...
 
Greg King's Avatar
 
Join Date: Jul 2005
Location: Indiana
Posts: 2,085
Default

Awesome! Having the ability to use the media keys is a plus. Glad we could help you out.
__________________
"It is far better to grasp the universe as it really is than to persist in delusion, however satisfying and reassuring."
- Carl Sagan

System:
Intel i5 2500K | Gigabyte GA-Z68XP-UD4 | 16GB G.Skill DDR3 | Crucial M4 128GB SSD
WD 1TB Black x1 | WD 2TB Green x 1 | EVGA 660 Ti Superclocked | Corsair H80 Water Cooler
Fractal Design R3 | Windows 7 Ultimate x64 | Dell 2410 x 3 @ 1920x1200

ESXi Host:
Intel i7 920 @ 3.0 GHz | Gigabyte GA-EX58-UD4P | 24GB Patriot DDR3 | WD 1TB Black x 2
Greg King is offline   Reply With Quote
Old 06-05-2007, 07:56 AM   #36
NewEclipseOwner
Guest Poster
 
Posts: n/a
Default winamp fix

Yup, thanks for the winamp fix

Sorted my issue too!

GJ DarkSynergy.
  Reply With Quote
Old 06-07-2007, 09:34 AM   #37
Greg King
I just kinda show up...
 
Greg King's Avatar
 
Join Date: Jul 2005
Location: Indiana
Posts: 2,085
Default

Thank you. Glad you are happy with the Eclipse II and I am glad you figured you what you needed.
__________________
"It is far better to grasp the universe as it really is than to persist in delusion, however satisfying and reassuring."
- Carl Sagan

System:
Intel i5 2500K | Gigabyte GA-Z68XP-UD4 | 16GB G.Skill DDR3 | Crucial M4 128GB SSD
WD 1TB Black x1 | WD 2TB Green x 1 | EVGA 660 Ti Superclocked | Corsair H80 Water Cooler
Fractal Design R3 | Windows 7 Ultimate x64 | Dell 2410 x 3 @ 1920x1200

ESXi Host:
Intel i7 920 @ 3.0 GHz | Gigabyte GA-EX58-UD4P | 24GB Patriot DDR3 | WD 1TB Black x 2
Greg King is offline   Reply With Quote
Old 06-09-2007, 10:24 AM   #38
Unregistered
Guest Poster
 
Posts: n/a
Default 3 Lit Function LED's At Top Of Keyboard

I just received my Eclipse II and love it so far, but I am wondering about the 3 LED's at the top of the keyboard. The are 'number lock', 'caps lock' and I cannot determine what the third one signifies. They are no discussed in the manual that comes with keyboard and I would like to know what it is.
  Reply With Quote
Old 06-09-2007, 01:58 PM   #39
ccdarkness
Obliviot
 
ccdarkness's Avatar
 
Join Date: Jun 2007
Location: Romania
Posts: 43
Default

usualy it's 'num lock' 'caps' and 'scroll lock'
__________________
AMD Athlon64 3200+@2000Ghz; Asus A8N5X; 1GB DDR; Asus EN7950GT 512DDR3 650/1550Mhz
ccdarkness is offline   Reply With Quote
Old 06-09-2007, 02:53 PM   #40
Unregistered
Guest Poster
 
Posts: n/a
Default

Thanks, I appreciate the answer.
  Reply With Quote
Old 06-19-2007, 10:38 PM   #41
Unregistered
Guest Poster
 
Posts: n/a
Default

I can't get the media keys to work at all. The only working extra button is the colour changer, but other than that its a great keyboard.
  Reply With Quote
Old 06-20-2007, 08:11 AM   #42
Greg King
I just kinda show up...
 
Greg King's Avatar
 
Join Date: Jul 2005
Location: Indiana
Posts: 2,085
Default

That is strange. What media player are you trying to control? I haven't had the media keys work off the bat with anything but Windows Media Player. With Foobar and Winamp, I had to manually map the keys. Let me know and I will try to help you out.
__________________
"It is far better to grasp the universe as it really is than to persist in delusion, however satisfying and reassuring."
- Carl Sagan

System:
Intel i5 2500K | Gigabyte GA-Z68XP-UD4 | 16GB G.Skill DDR3 | Crucial M4 128GB SSD
WD 1TB Black x1 | WD 2TB Green x 1 | EVGA 660 Ti Superclocked | Corsair H80 Water Cooler
Fractal Design R3 | Windows 7 Ultimate x64 | Dell 2410 x 3 @ 1920x1200

ESXi Host:
Intel i7 920 @ 3.0 GHz | Gigabyte GA-EX58-UD4P | 24GB Patriot DDR3 | WD 1TB Black x 2
Greg King is offline   Reply With Quote
Old 08-23-2007, 07:33 AM   #43
Unregistered
Guest Poster
 
Posts: n/a
Unhappy Disappointed

Had a Saitek Eclipse found the key finish to be very poor, why oh why were they not treaded to a think coating of laquer to protect the surface against the abrading action of typing? As a heavy user of my machine, I was also disappointed when certain key functions quit after just 14 months, silly stuff like "underscore" no longer work... so deciding to give Saitek a chance to redeem themselves I upgraded to an Eclipse2 and found the illumination very poor, on the right hand side of mine the purple lighting turns to pretty much blue, and there is a triangular area to the left of the main enter key that is very dim compared to the rest of the keyboard when using the red illumination, and is certainly not as uniform as the illustration on their advertising shots and on the packaging suggests.

I RMA'd it but was told by the supplier that it is operating correctly, and so I have rejected the goods under the distance selling regs we have in the UK. I also put in a call to Saitek UK and told the support team of the problem they seem to feel that the lighting should be pretty uniform across the keyboard and have taken the RMA number and are contacting the supplier directly to investigate further.

In all I am this far unimpressed with Saitek, I will update this if I get any news ut Right now I am looking at the Logitec range, thankfully there is more than one player in this market
  Reply With Quote
Old 08-23-2007, 01:04 PM   #44
Greg King
I just kinda show up...
 
Greg King's Avatar
 
Join Date: Jul 2005
Location: Indiana
Posts: 2,085
Default

Sorry to hear that your having problems. I hope that Saitek USA can help you out more than what you have received so far. Honestly, I have not worked with anything from Saitek other than their keyboards so I dont know about their quality across the board. However, with the Eclipse line, I have had nothing but positive results.

I certainly hope that your fortunes change. Good luck.
__________________
"It is far better to grasp the universe as it really is than to persist in delusion, however satisfying and reassuring."
- Carl Sagan

System:
Intel i5 2500K | Gigabyte GA-Z68XP-UD4 | 16GB G.Skill DDR3 | Crucial M4 128GB SSD
WD 1TB Black x1 | WD 2TB Green x 1 | EVGA 660 Ti Superclocked | Corsair H80 Water Cooler
Fractal Design R3 | Windows 7 Ultimate x64 | Dell 2410 x 3 @ 1920x1200

ESXi Host:
Intel i7 920 @ 3.0 GHz | Gigabyte GA-EX58-UD4P | 24GB Patriot DDR3 | WD 1TB Black x 2
Greg King is offline   Reply With Quote
Old 09-11-2007, 04:18 PM   #45
ryan92084
Obliviot
 
Join Date: Sep 2007
Posts: 11
Default

i also thoroughly enjoy the eclipse line
my first eclipse died after 3 years for a mysterious reason but that did not at all cause me to hesitate in purchasing a new eclipse II

haven't had a chance to play with the media keys but i find the lighting in the new model to definately be improved and the keys are quieter and seem more responsive
ryan92084 is offline   Reply With Quote
Reply

Tags
None

Thread Tools

Posting Rules
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
EVGA 3D Eclipse Giveaway Ends Nov. 14 eunoia Contests 5 11-28-2012 07:45 PM
Saitek X-52 Pro Flight Control System Rob Williams Reviews and Articles 21 07-05-2010 08:52 PM
Logitech Illuminated Keyboard Rob Williams Reviews and Articles 14 05-19-2010 08:37 AM
Total Solar Eclipse on Wednesday, But There's a Catch... Rob Williams Off Topic 6 07-23-2009 03:08 AM
Logisys Black Illuminated Keyboard Rob Williams Reviews and Articles 10 10-30-2006 03:59 PM


All times are GMT -4. The time now is 12:13 AM.